Broadcom, b42-fwcutter & b43-phy0 ERROR still stuck

arcas2001-lunar at arcas2001-lunar at
Sat Feb 5 12:39:19 CET 2011

Thanks for your input, but I still do not understand how to fix this.

If I do "lspci -vnn | grep 14e4", I get this:

"0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)"

According to "" I got this info about my card:

"pci-id: 4e4:4315
supported: partially in 2.6.33 and later
modes: b/g
phy version: LP
alternative: wl"

According to that site, given my driver and card model I must:

"Install b43-fwcutter, then use version of Broadcom's proprietary driver. (The tarball is mislabeled as "", but it is actually"

So I installed b43-fwcutter from the lunar base (version 13), downloaded the tarball, extracted, and run the following command:

b43-fwcutter -w /lib/firmware wl_apsta.o.

I got a lot of files in a newly created /lib/firmware/b43 folder, but dmesg still shows the same error.

I also tried installing the broadcom-wl from lunar, but got the same result.

I do not got ndiswrapper installed.

I do not know what else to do, when you talk about new drivers what do you mean (I think I got the latest tarball with the wl_apsta.o )? Getting a newer kernel or kernel module? I am quit lost when it comed to handling the kernel (first source distro I try), any guide about how to update wifi drivers?



More information about the Lunar mailing list