linux-2.6 module: Choose SLAB allocator endless loop

Zbigniew Luszpinski zbiggy at
Wed Jul 11 14:01:54 CEST 2007

Wednesday 11 of July 2007 13:25:46 Duncan Gibson wrote:
> > Someone tried kernel 2.6.22(.1) (linux-2.6 module) and ended up with:
> > "Choose SLAB allocator
> >
> >> 1. SLAB (SLAB)
> >
> >   2. SLUB (Unqueued Allocator) (SLUB) (NEW)"
> > endless loop flying thru the screen?
> > Just would like to know if this is global bug or it is just my machine
> > only.
> I ran "lunar update" last night and picked up the latest linux-2.6(.22)
> but I always say Yes to configure the kernel, even though I just exit
> immediately from the "make menuconfig" screens. Otherwise the update
> runs "make oldconfig" and that can give the endless input loop problem
> that you describe. IIRC, it can also loop on processor type selection.

Not this one. I always say [y] too. Then in kernel menu load file 2622 with my 
config I use in all kernels. After loading I review and fine tune all options 
and save config to file with current kernel version (that is why I write 
about 2622 file) and then do ESC, ESC. I have never had such problem before.
I use this way of kernel configuring since 3 years.

In attachment bziped 2622 file (I tested it too with Maybe someone 
would be interested in trying it. The SLAB problem appears in few seconds 
after hitting ESC,ESC to quit menuconfig. No needed to wait till compilation 

I tried to manually do make. Then SLAB question is not looped but appear once.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 2622.bz2
Type: application/x-bzip2
Size: 8832 bytes
Desc: not available
Url :

More information about the Lunar mailing list