I surrender

Auke Kok sofar at lunar-linux.org
Fri Apr 29 07:17:43 UTC 2005

Richard Pyne wrote:

>I give up! Tomorrow I'm going to start looking for another 
>distro to try on my laptop, probably Mandrake or Redhat. I have 
>been using Lunar on my servers since the 1.2 iso came out, and 
>will continue using for my server, but for a desktop with X, 
>Two months ago, my employer presented me with a brand new Dell 
>Inspiron 6000 laptop. Having a 60 Gig drive, I was elated that 
>there would be enough space to make it multi-boot so I could use 
>Linux for everything other than the few things that gave me no 
>So, I grabbed a copy of Partition Magic and shrunk the NTFS 
>partition down to 10 Gig and grabbed the CD of my favorite Linux 
>distro - Lunar. Things went quite well through the basic install 
>even thought there were some minor glitches getting the NIC to 
>work. Even the switch to the 2.6 kernel and patching it for mppe-
>mppc went relatively smooth. All was well, I had a good base 
>system, complete with drivers for both the wireless (using 
>ndiswrapper), the hardwire networking, and even successfully 
>connecting to the office PPTP tunnel.
>I decided to get a KDE desktop up. Not too bad, a few hangups 
>with dependencies and some struggles getting it configured for 
>my oddball 1280 x 800 wide screen video. Things seemed to be 
>working fine.
>Then the problems started, the new KDE update came out in 
>moonbase. The lunar upgrade took most of a night to upgrade, but 
>then I could no longer log in under KDE. As soon as I would try, 
>X would crash and restart. The log said something about an 
>authentication error. After fighting with it for a few days, I 
>ended up with X (Xorg) working, but only with a default desktop, 
>not KDE. After trying to re-lin KDE hoping that it would solve 
>the problem, I still could not get KDE to start.
>Well, after two weeks of frustration, I decided to take drastic 
>steps and wipe out the Linux install and start fresh.
>Installing KDE after gettng the base OS back on went fairly 
>well, even though there were a couple of missing dependencies. 
>Everything went well until I rebooted to level 5 and tried to 
>log in with KDE. Actually, the login worked alright, but about 
>half way through the "initializing peripheral" part, KDE and/or 
>X crashed, restarted and presented me with a login screen again. 
>Not a hint of what went wrong showed up in any of the logs. 
>After re-linning most of KDE with no improvement, I decided to 
>try installing gnome2, after all, gnome is a good workable 
>desktop. That was five days ago. Again, there were missing 
>dependencies and modules that couldn't download. Tonight's 
>frustration comes from the compile of cairo (required by firefox 
>which is required by gnome2) It fails with:
> gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I/usr/X11R6/include -I/usr/include/libpng12 -I/usr/include/freetype2 -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -O2 -mcpu=pentium4 -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse,387 -MT cairo_glitz_surface.lo -MD -MP -MF .deps/cairo_glitz_surface.Tpo -c cairo_glitz_surface.c  -fPIC -DPIC -o .libs/cairo_glitz_surface.o
>cairo_glitz_surface.c: In function `_cairo_glitz_surface_get_image':
>cairo_glitz_surface.c:122: error: structure has no member named `red_size'

this was filed as a bug: without glitz cairo should compile fine. Most 
likely glitz will be taken out for now.


More information about the Lunar mailing list