Disaster help!

Richard Pyne rpyne at kinfolk.org
Tue Nov 16 04:24:30 UTC 2004

On 11 Nov 2004 at 9:36, Auke Kok wrote:

> Richard Pyne wrote:
> >While updating a few modules on a Lunar 1.4 linux-stable machine
> > that hadn't been updated in about 6 months, I one of the
> >modules triggered an auto re-lin of glibc and now I am getting:
> >
> >/sbin/lunar: line 65: /bin/sleep: Permission denied
> >Waiting to lock the file /var/state/lunar/depends
> >
> >repeating continuously. All logins are disabled, however 
> >existing sessions still work and the firewall is still routing.
> >
> >Any suggestions will be appreciated greatly.
> >  
> >
> ouch those suck... it usually happens when your coreutils etc are
> in really old locations, programs get moved around etc. I would
> try to start updating your core first and then moonbase, if those
> already fail it could be that libc.so is not found or something
> similar. Here's a few tricks

ldconfig seemed to do the trick to make the system (mostly) 

I updated everything else that would, which is everything except 
lynx and dialog which both configures say it can't find curses.

Then I tried again to update glibc. The same thing happened. I 
did an ldconfig from another console session I had open and that 
seemed to make things work again, but glibc is still not 

I had enough scroll-back to get back to where it went sour. It 
looked like it went crazy the part of BUILD that does the strip. 
It looked like it couldn't find the files that it was supposed 
to strip.


More information about the Lunar mailing list