If you recently lost ability to switch from X console to text consoles or your non US chars can not be typed in - read this

Zbigniew Luszpinski zbiggy at o2.pl
Sun Apr 1 15:43:57 CEST 2007

> what error do you get when you:
> setxkbmap -rules xorg -model acpi -layout pl  ?
> Might this be the error? :
> Error loading new keyboard description

Yes. Always.

> Do you still get the error when you mkdir -p /var/lib/xkb ?

Yes. This empty directory is always present.

> and do you have the file /usr/share/X11/xkb/compiled ? which should be
> a symlink to /var/lib/xkb

Yes. This symlink is always present.

> This is a bit awkward and might well be a bug in xkeyboard-config...
> still reinstall xkeyboard-config and try this plz...

Done. Still nothing.

> I'd like it very 
> much if you could open a bug report for this. Even if all is solved
> with the creation of the /var/lib/xkb.

The only thing to check is to install clean system and lin xorg.
I'll do this at night. If only my machine is broken this will not help 
anybody. If I spot the bug will put a fix to svn.

To developers of future ISO image: give write rights to xserver for /var/tmp 
to fix:
(EE) Error loading keymap /var/tmp/server-0.xkm
(EE) Error loading keymap /var/tmp/server-0.xkm
in Xorg.0.log
This is necessary for normal users.
People running on root accountonly  all the time will not see the difference.


More information about the Lunar mailing list