Fun with installation

Matt Dee foggerty at
Wed Oct 1 23:09:58 GMT 2003

Hello, new to this list (sorta) so a quick introduction -

I've tried Lunar Linux in the past and got as far as (almost) getting X up 
and running before I decided that maybe I should learn more about how Linux 
works before using a source based distro.  (I've used Mandrake for a while 
now).  I then went and did a Linux From Scratch install, and even got X and 
Fluxbox etc up and running.

I know a fair bit more about what I'm doing now (though still in the dark 
about a fair few things) and so want to give Lunar another try :-)

Anyway, the problem I'm having is that when the install routine tries to 
run Menuconfig I get massive amounts of error messages, pretty much all of 
them from tar indicating that it cannot find files.  It looks like it 
cannot find every single file from the linux-2.4.20 directory (i.e. the 
kernel).  Note that I've partioned the drive into two (root and swap), its 
a secondary drive (W2K on the first) and I've tried mounted it with both 
Reiser and Ext3.

After that, I get the following:

! Error while unpacking /var/spool/lunar/linux
cp cannot create regular file  '/usr/src/linux/linux.config': no space left 
on device
! problem detected during build
...don't have permission to access /var/log/lunar/activity.562

Also, earlier on in the install I noticed a couple of errors:

tar /moonbase/zlocal/filename could not find
tar /moonbase/zbeta/filename could not find

I've tried this several times now, same result each time.

Sorry for the long post :-)


More information about the lunar mailing list