[Fwd: lilo-22.5..............]

Chris da2gnu at lycos.de
Sat Mar 8 20:33:01 GMT 2003

rcrongeyer at rpicc.com wrote:
> Hi all,
> Yesterday I did an update and one of the modules was lilo. After it
> installed I ran /sbin/lilo -v as I usualy do, and went on with my day of
>  work (without rebooting). This morning I fired up my laptop and was
> greeted with 01 01 01 01 wraped over the first 1/4 of my screen
> (corruped MBR). I tried lrm -d lilo 22.4.1 and it says lilo is a
> "sustained" module but then says Rolled back lilo to version 22.4.1 
> then I lin lilo and it says Reserecting lilo 22.4.1 but when it is
> finished I run /sbin/lilo -V and it is still at version 22.5 
> So,  how do you roll back to an old version of a "sustained" module??
> Also when lilo runs it says it can't determin what type of video card is
>  in the current system? I don't know if the 22.4.1 version had the same
> message or not?
> How do I fix this??
> Ralph

Hi Ralph,

I had the same error. To get 22.4.1 back I did the following (there 
might be better solutions...):

1. dl lilo-22.4.1 
and put it into /var/spool/lunar

2. edit /var/lib/lunar/moonbase/utils/lilo/DETAILS to VERSION=22.4.1 and 
comment out SOURCE_MD5

3. lin -r -c lilo

4. put it onto the hold list until 22.5 is fixed


More information about the Lunar mailing list